当前位置:首页 > 问答

指南针成本均线指标公式

我来帮TA回答

指南针公式源码如何导入指标平台

飞狐,大智慧通用指南针指标公式(一共21个公式)原码
1,CYW主力控盘
VAR1:=CLOSE-LOW;
VAR2:=HIGH-LOW;
VAR3:=CLOSE-HIGH;
VAR4:=IF(CLOSE>=0,(VAR1/VAR2+VAR3/VAR2)*VOL,(VAR3/VAR2+VAR1/VAR2)*VOL);
SUM(VAR4,10)/10000, COLORSTICK;
2,CYW-YJJ主力控盘
VAR1:=1;
VAR2:=CLOSE-REF(CLOSE,1);
VAR3:=IF(CLOSE-REF(CLOSE,1)>=0,VAR2,0);
VAR4:=REF(CLOSE,1)-CLOSE;
VAR5:=IF(CLOSE-REF(CLOSE,1)<=0,VAR4,0);
VAR6:=SUM(VAR3,P1)/SUM(VAR5,P1);
VAR7:=100-100/(1+VAR6);
VAR8:=EMA(VAR7,P1);
VAR9:=EMA(VAR8,P2);
VARA:=EMA(VAR8,P3);
MO: (VAR8-VARA)*VAR1;
ML: (VAR9-VARA)*VAR1;
MODE: MO*VAR1, COLORSTICK;
p1:=0,100,6
p2:=0,100,8
p3:=0,100,45
3,CYS盈亏指标
Var1:=AMOUNT/(100*VOL);
Var2:=MA(Var1,N1);
Var3:=MA(Var1,N2);
Var4:=MA(Var1,N3);
Var5:=DMA(CLOSE,VOL/CAPITAL);
CYS5: 100*(CLOSE-Var2)/Var2;
CYS13: 100*(CLOSE-Var3)/Var3;
CYS34: 100*(CLOSE-Var4)/Var4;
CYS无穷: 100*(CLOSE-Var5)/Var5;
n1:=0,100,5
n2:=0,100,13
n3:=0,100,34
4,CYE市场趋势
MAL:=MA(CLOSE,5);
MAS:=MA(MA(CLOSE,20),5);
CYEL:MAL-REF(MAL,1)/REF(MAL,1)*100;
CYES:MAS-REF(MAS,1)/REF(MAS,1)*100;
5,CYR市场强弱
DIVE:=0.01*EMA(AMOUNT,N)/EMA(VOL,N);
CYR:=DIVE/REF(DIVE,1)-1*100;
MACYR:MA(CYR,M);
n:=0,100,13
m:=0,100,5
6,CYQKL博弈K线
100*(WINNER(CLOSE)-WINNER(OPEN)), COLORSTICK;
7,CYOBV优化累积能量
NOBV1: SUM(IF(CLOSE>REF(CLOSE,1),VOL,IF(CLOSE<REF(CLOSE,1),0-VOL,0)),N)/CAPITAL;
n:=0,100,34
8,CYF市场能量
HSL:=VOL/CAPITAL*100;
CYF:100-100/(1+EMA(HSL,N)*100);
n:=0,100,21
9,CYDD动态承接
Var1:=WINNER(CLOSE);
Var2:=DMA(Var1,VOL/CAPITAL);
Var3:=DMA(VOL,VOL/CAPITAL)/CAPITAL;
CYDD: Var1/Var3;
CYDD1: Var2/Var3;
1, POINTDOT;
10,CYD2承接因子
A:=WINNER(CLOSE )*CAPITAL;
承接因子:A/VOL;
11,CYD承接因子
CYDS:WINNER(CLOSE)/(VOL/CAPITAL);
CYDN:WINNER(CLOSE)/MA(VOL/CAPITAL,N);
n:=0,100,21
12,CYC2成本均线
CYC1:0.01*EMA(AMOUNT,n1)/EMA(VOL,n1);
CYC2:0.01*EMA(AMOUNT,n2)/EMA(VOL,n2);
CYC3:0.01*EMA(AMOUNT,n3)/EMA(VOL,n3);
CYC∞:DMA(AMOUNT/(100*VOL),VOL/(100*FINANCE(7)));
n1:=0,100,5
n2:=0,100,13
n3:=0,100,34
13,CYC1成本均线
Var1:=AMOUNT/(100*VOL);
短线成本均线: MA(Var1,N1);
中线成本均线: MA(Var1,N2);
长线成本均线: MA(Var1,N3);
无穷成本均线: DMA(CLOSE,VOL/CAPITAL);
STICKLINE(open>=close ,close ,open,9,0 ),COLORaaaaaa;
STICKLINE(open>=close ,close ,open,6,0 ),COLORbbbbbb;
STICKLINE(open>=close ,close ,open,2.4,0 ),COLORcccccc;
STICKLINE(open>=close ,close ,open,1.1,0 ),COLORdddddd;
STICKLINE(close>open,close,open,9,0 ),COLOr6666cc;
STICKLINE(close>open,close,open,6 ,0 ),COLOR7777dd;
STICKLINE(close>open,close,open,2.4 ,0 ),COLOR8888ee;
STICKLINE(close>open,close,open,1.1 ,0 ),COLOR9999ff;
STICKLINE(close>open,open,low,0.5,0 ),COLOR1199ff;
STICKLINE(close>open,close,HIGH,0.5 ,0 ),COLOR1199ff;
STICKLINE(open>=close,close,low,0.5 ,0 ),COLORcccccc;
STICKLINE(open>=close,open,HIGH,0.5 ,0 ),COLORcccccc;
n1:=0,100,5
n2:=0,100,13
n3:=0,100,34
14,CYB优化布林线
MB: MA(CLOSE,N);
上轨: MB+STD(CLOSE,N);
下轨: MB-STD(CLOSE,N);
上极限: MB+2*STD(CLOSE,N);
下极限: MB-2*STD(CLOSE,N);
STICKLINE(open>=close ,close ,open,9,0 ),COLORaaaaaa;
STICKLINE(open>=close ,close ,open,6,0 ),COLORbbbbbb;
STICKLINE(open>=close ,close ,open,2.4,0 ),COLORcccccc;
STICKLINE(open>=close ,close ,open,1.1,0 ),COLORdddddd;
STICKLINE(close>open,close,open,9,0 ),COLOr6666cc;
STICKLINE(close>open,close,open,6 ,0 ),COLOR7777dd;
STICKLINE(close>open,close,open,2.4 ,0 ),COLOR8888ee;
STICKLINE(close>open,close,open,1.1 ,0 ),COLOR9999ff;
STICKLINE(close>open,open,low,0.5,0 ),COLOR1199ff;
STICKLINE(close>open,close,HIGH,0.5 ,0 ),COLOR1199ff;
STICKLINE(open>=close,close,low,0.5 ,0 ),COLORcccccc;
STICKLINE(open>=close,open,HIGH,0.5 ,0 ),COLORcccccc;
n:=0,100,13
15,CMACD指标
Var1:=AMOUNT/(100*VOL);
Var2:=MA(Var1,N1);
Var3:=MA(Var1,N2);
CMACD: 100*(Var2-Var3)/Var3, COLORSTICK;
n1:=0,100,5
n2:=0,100,13
16,CBXQD成本均线
Var1:=AMOUNT/(100*VOL);
Var2:=MA(Var1,N1);
Var3:=MA(Var1,N2);
Var4:=MA(Var1,N3);
Var5:=DMA(CLOSE,VOL/CAPITAL);
CYR5: 100*(Var2-REF(Var2,N))/REF(Var2,N);
CYR13: 100*(Var3-REF(Var3,N))/REF(Var3,N);
CYR34: 100*(Var4-REF(Var4,N))/REF(Var4,N);
CYR无穷: 100*(Var5-REF(Var5,N))/REF(Var5,1);
n:=0,100,4
n1:=0,100,5
n2:=0,100,13
n3:=0,100,34
17,CBW成本带宽
CBW: 100*(COST(N1)-COST(N2))/COST(N1);
n1:=0,100,98
n2:=0,100,2
18,CBAND布林线宽
Var1:=MA(CLOSE,N);
Var2:=Var1+2*STD(CLOSE,N);
变盘: 5, POINTDOT;
布林宽度: (Var2-Var1)/Var1*100;
警戒: 30, POINTDOT;
n;=5,100,30
20,指南针CYE
顶部: 4,COLORBLUE;
强势: 1,COLORRED;
弱势: -1,colorf00ff0;
底部: -4,COLORWHITE;
短期趋势: (MA(CLOSE,5)-REF(MA(CLOSE,5),1))/REF(MA(CLOSE,5),1)*100,COLORWHITE,LINETHICK2;
中期趋势: (MA(MA(CLOSE,13),5)-REF(MA(MA(CLOSE,13),5),1))/REF(MA(MA(CLOSE,13),5),1)*100,colorf00ff0,LINETHICK2;
长期趋势: (MA(MA(CLOSE,34),5)-REF(MA(MA(CLOSE,34),5),1))/REF(MA(MA(CLOSE,34),5),1)*100,COLORRED,LINETHICK2;
21,0ama
Var1:=SMA("AMOUNT",10,1)/10000000;
Var2:=REF(Var1,1);
AA: STICKLINE(Var1>Var2,Var1,Var2,8,1),COLORRED;
AD: STICKLINE(Var1<Var2,Var1,Var2,8,0),COLORGREEN;
C5: DMA(SMA(Var1,3,1),VOL/0.02/CAPITAL);
C13: DMA(SMA(Var1,5,1),VOL/0.1/CAPITAL);
C34: DMA(SMA(Var1,8,1),VOL/0.18/CAPITAL);

同花顺【成本均线】&【 指南针成本均线】 的区别。

计算对象不同。

为什么有的股票的CYC中绝对成本均线远在所有筹码之上?

你只要知道主力庄家的成本在什么位置就够了,目前所处的位置是什么,趋势、位置、形态,再到成本,这些才是你要该考虑的问题

通达信 amv 成本均线源码指标公式?

SWAAMOV:=VOL*(OPEN+CLOSE)/2;


AMV1:SUM(AMOV,M1)/SUM(VOL,M1);


AMV2:SUM(AMOV,M2)/SUM(VOL,M2);


AMV3:SUM(AMOV,M3)/SUM(VOL,M3);


AMV4:SUM(AMOV,M4)/SUM(VOL,M4);

注意参数如图


指南针股票元件主力资金,散户资金表示什么?

他说的主力资金就是大机构或者是基金公司等有大资金的单位,散户资金就是资金比较少的个人投资者。

指南针股票里面三把锁,加号,减号,一把开锁什么意思?

三把锁分别对应着趋势,资金和活跃度,如果三把锁在一起出现,代表着其通过数据分析推荐的建仓位置。加号代表买入建议,减号代表卖出建议。注意投资有风险。